Resolved
All services have been fully restored. The outage lasted many hours due to a data center power failure and subsequent control plane recovery issues.
Full report: https://docs.strettch.com/s/8c3854ed-ce12-4ac9-b7ee-c25a39c77569
Monitoring
Control plane and routing issues have been resolved. Recovery commands are being issued to progressively restore compute instances.
We are monitoring progress.
Identified
A total power failure at our upstream data center caused the outage.
Power has been restored, but services are not recovering automatically.
Our team is working on manual restoration.
Investigating
Compute instances and platform services are currently unavailable.
We are investigating the cause.